Neon drop · Free ship $75+ · Enter the grid
Signal · Product Feed

Cisco WS-C3650-48FD-L 48 Port Full PoE 2x10G Switch (Used - Good) Speakers and Systems W/O Receiver Rack Mountable

SKU: 95184995845

4.3
USD80.00 USD113.00

Pay in 4 interest-free payments of $20.00 Learn more

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 5 - Oct 10

Live Spec

Cisco WS-C3650-48FD-L 48 Port Full PoE 2x10G Switch (Used - Good) Speakers and Systems W/O Receiver Rack MountableCondition: Used Good Brown White Box Warranty Term: 30 Warranty Provider: Distributor Cisco WS C3650 48FD L 48 Port Full PoE 2x10G Switch (Used Good) The Cisco Catalyst 3650 Series is the next generation of enterprise class standalone and stackable access layer switches that provide the foundation for full convergence between wired and wireless on a single platform. The 3650 Series is built on the advanced Cisco StackWise 160, and takes advantage of

Store: yutopean.com · Domain: yutopean.com

Description

Rack Mountable

Protocols: • RFC 1662 PPP in High-Level Data Link Control (HDLC)-like framing • RFC 2615 Point-to-Point Protocol (PPP) over SONET/SDH • RFC 2427

CPU Socket: LGA 775

Features and Benefits of Cisco ASA with FirePOWER Services Feature Benefits Next-generation firewall Industry’s first threat-focused NGFW

Enterprise-Class

Cisco WS-C3650-48FD-L 48 Port Full PoE 2x10G Switch (Used - Good) Speakers and Systems W/O Receiver Rack MountableCondition: Used Good Brown White Box Warranty Term: 30 Warranty Provider: Distributor Cisco WS C3650 48FD L 48 Port Full PoE 2x10G Switch (Used Good) The Cisco Catalyst 3650 Series is the next generation of enterprise class standalone and stackable access layer switches that provide the foundation for full convergence between wired and wireless on a single platform. The 3650 Series is built on the advanced Cisco StackWise 160, and takes advantage of

Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy

You may also like

recommand products