Neon drop · Free ship $75+ · Enter the grid
Signal · Product Feed

1024GB (64 x 16GB) DDR3-1600 MHz PC3-12800R ECC Registered Server Memory Upgrade Kit - Supermicro 4X77A93532 Registered Server Memory Energy Efficient: ENERGY STAR® certified

SKU: 35649944034

4.8
DKK1151.62 DKK1184.62

Pay in 4 interest-free payments of $287.90 Learn more

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Sep 30 - Oct 5

Live Spec

1024GB (64 x 16GB) DDR3-1600 MHz PC3-12800R ECC Registered Server Memory Upgrade Kit - Supermicro 4X77A93532 Registered Server Memory Energy Efficient: ENERGY STAR® certifiedModule Name: PC3 12800R Type: Registered Speed: 1600MHz Data Integrity Check: ECC Kit Storage Capacity: 1024GB (64 x 16GB) Condition: Fully Tested, Refurbished Warranty: 1 Year Warranty none

Store: yutopean.com · Domain: yutopean.com

Description

Energy Efficient: ENERGY STAR® certified for reduced operational costs

hard_drive 960 GB Solid State Drive brand Lenovo series S4500 item_model_number 4XB7A13627 item_weight 2

3 (alarm) and 9 (events) RFC 6398 IP Router Alert Considerations and Usage ANSI/TIA-1057 LLDP Media Endpoint Discovery (LLDP-MED) SNMPv1/v2c/v3 OSPF RFC 1587 OSPF NSSA RFC 1850 OSPFv2 Management Information Base (MIB)

disassembly for recalibration and all this with a measurement accuracy that is comparable to that of the built-in sensors

The Delta Electronics DPS-700LB D is a genuine 750W autoranging switching power supply with single-fan cooling

1024GB (64 x 16GB) DDR3-1600 MHz PC3-12800R ECC Registered Server Memory Upgrade Kit - Supermicro 4X77A93532 Registered Server Memory Energy Efficient: ENERGY STAR® certifiedModule Name: PC3 12800R Type: Registered Speed: 1600MHz Data Integrity Check: ECC Kit Storage Capacity: 1024GB (64 x 16GB) Condition: Fully Tested, Refurbished Warranty: 1 Year Warranty none

Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy

You may also like

recommand products